exelisvis.com / Docs Center / Using ENVI / What's New in ENVI 5.1

ENVI

What's New in ENVI 5.1

What's New in This Release

ENVI 5.1 includes the new and enhanced features listed below. See the following sections:

Featured Updates


The new Seamless Mosaic workflow combines multiple georeferenced scenes into one image. It provides several features to create a quality mosaic such as seamline creation and editing, edge feathering, and color correction.

The new Region of Interest (ROI) Tool lets you define and manage ROIs as follows:

  • Draw geometry. This includes drawing a polygon, rectangle, ellipse, polyline; selecting a discrete point; and, if desired, combining geometry into a multi-part ROI.
  • Select one or more pixels.
  • Grow ROIs from neighboring pixels.
  • Create ROIs from band thresholds.
  • Open and convert an ENVI Classic .roi to a georeferenced (.xml) ROI.
  • ENVI programmers can automate many ROI functions.
  • ROIs are no longer tied to an image of a certain size but can be transferred from image to image.

The new Spectral Profile and Spectral Library Viewer provide improved interactive analysis and plot functions. New Plot Preferences set the default look for these windows.

New Horizontal (X) and Vertical (Y) Profiles plot pixels that fall along the horizontal or vertical cursor line, respectively. A new Arbitrary Profile Profile tool is also available, to plot pixels that lie beneath a transect. New Plot Preferences set the default look for these windows.

Updated spectral libraries are included with the ENVI installation. These include over 6,500 new spectra from the following sources: ASTER Spectral Library Version 2, U.S. Geological Survey Digital Spectral Library 06, Johns Hopkins University, and NASA Jet Propulsion Laboratory.

The new ENVIRPCOrthorectificationTask programming routine performs rational polynomial coefficient (RPC) orthorectification in batch mode.

ENVI can open generic HDF5 files. Use the Select HDF5 Datasets dialog to build raster files from a combination of different 2D and 3D components. Also use this dialog to create an ENVI Meta file from the HDF5 datasets and to save and restore HDF5 templates.

ENVI supports interoperability with ArcGIS® 10.2 software, with the following exceptions: 

  • No read/write support for version 10.2 Enterprise/SDE geodatabases
  • No support for the Print Layout functionality.

Data Types


ENVI reads and displays imagery from the following data types:

  • Active Fires product from NPP VIIRS
  • ECRG
  • EDR derived products from NPP VIIRS
  • GeoEye-1 in DigitalGlobe format (.til)
  • Göktürk-2
  • KOMPSAT-3
  • NigeriaSat-1 and -2
  • PDS
  • RapidEye Level-3B Area-based Ortho
  • RASAT
  • ResourceSat-2
  • SICD (NITF format)
  • SSOT (FASat-Charlie)

Use the File > Open menu to open BMP, DTED, and GIF files.

Use the File > Open World Data menu to open the following sample data files provided with the ENVI installation:

  • Shapefiles of world airports, coastlines, countries, geographic lines, lakes, minor islands, populated places, ports, rivers, roads, and states/provinces. Data courtesy of Natural Earth. Free vector and raster map data are available at naturalearthdata.com.
  • GMTED2010: Global Multi-resolution Terrain Elevation Data 2010, 30-arc-second mean resolution, JPEG2000 format.
  • Shaded relief map

Landsat 8 data support has been updated as follows:

  • ENVI reads thermal infrared (K1 and K2) coefficients from the associated _MTL.txt metadata files.
  • Quality and Cirrus cloud bands are listed as separate bands in the Data Manager and Layer Manager.
  • Reflectance gains and offsets are automatically corrected for solar elevation.
  • FLAASH® works with Landsat 8 data.

Use the Open Remote Dataset dialog and the ENVI::OpenRaster method to open raster catalog items from Esri® Image Services.

JPIP and IAS streaming are supported on Windows 64-bit platforms.

Image Processing


The Image Registration workflow has an option to define a custom output pixel size.

Use the Reproject GLT with Bowtie Correction tool to georeference MODIS imagery and to correct for bowtie visual artifacts.

The Toolbox no longer includes the ENVI Classic Georeferenced Mosaicking tool; you are encouraged to use the new Seamless Mosaic tool.

The speed of the RPC Orthorectification workflow has increased by 25x.

The RPC Orthorectification workflow and Image Registration workflow both use the GMTED2010 digital elevation model (DEM) by default, unless you specify a different DEM.

The RPC Orthorectification workflow has an option to specify a Grid Spacing value. This represents the grid spacing in output pixels, for which ENVI finds the corresponding pixels in the input images through an RPC-based transform.

A new tutorial demonstrates how to use FLAASH® to correct AVIRIS hyperspectral data for atmospheric effects.

A new tutorial shows how to use the Spectral Profile and Spectral Library Viewer to analyze AVIRIS hyperspectral data.

The THOR hyperspectral material identification tool includes an ACE algorithm for spectral comparison. It provides a probability score for interpreting the results of material identification based on Bayesian statistics calculations.

Access to Esri® Image Services is faster due to a new caching mechanism; it also supports Mosaic Method by attribute.

The NITF BANDSB and GEOLOB tagged record extensions (TREs) have improved support.

The Department of Defense (DoD) plug-in from Exelis includes a new Report Generator tool. The Mensuration Services Program (MSP) Interface has been updated to support version 1.2. DoD customers can download the plug-in from Intellipedia.

User Interface


The Spectral Library Viewer and Select Coordinate System dialogs contain a Search field, making it easier to find a given spectral signature or coordinate system, respectively.

Raster and vector layers are displayed accurately, regardless of mixed coordinate systems and/or datums in the same view. High-resolution local datasets and low-resolution global datasets also display accurately together in the same view.

Use the Open Remote Dataset dialog or the ENVI::OpenRaster API method to open file, personal, and enterprise geodatabases.

The Vector Properties dialog offers a simpler workflow for changing display properties of vector attributes and unique attribute values. Access the Vector Properties dialog by double-clicking a vector layer name in the Layer Manager.

Vector polygons show an accurate fill, regardless of the viewing scale. The default outline color for vector polygons is black when displaying vectors using a color palette.

ENVI includes a default set of keyboard shortcuts for accessing common functions. You can also define and save your own shortcuts for menu bar options, toolbar functions, toolbox items, and opening frequently used data files.

Text annotations support Ctrl-V paste and Ctrl-C copy with the operating system clipboard. Text annotations no longer resize after they are completed, and they now retain their display size upon zooming in or out.

Rename layers by right-clicking in the Layer Manager and selecting Rename Item. Enter the new name in the Rename Item dialog and press the Enter key to accept it or press the Esc key to cancel. (Linux and Macintosh users should click the green check icon to accept the new name or click the red X icon to cancel.)

The ENVI Help conforms to the HTML5 web specification and displays in your system's default web browser.

Use the mouse scroll wheel to zoom in or out of the display when the Zoom button is active. Hold down the Shift key while scrolling for a faster zoom. Hold down the Ctrl key while scrolling for a slower zoom.

The following fields are new options for customizing the Status Bar:

  • NITF Security Banner: The highest security level when multiple NITF layers are displayed
  • Raster Data Values: The pixel values for the top-most raster layer in the Layer Manager
  • Pixel Coordinates: The x,y pixel coordinates

Save and restore the layers of an ENVI session through the ENVI user interface, or by using the ENVI::SaveSession and ENVI::RestoreSession API methods.

A new File Selection dialog offers more options for selecting data from disk or remote sources; it also provides an easier way to create spectral subsets from multispectral data.

ENVI includes the following new preferences:

Preference

Category

Description

Restore Messages

Application

Some ENVI dialogs have a "Do not ask me again" option in cases where you repeatedly select the same button and do not want to be prompted each time. If you select this option for one or more dialogs but later decide that you need them, click in the Restore Messages preference.

Remember Input/Output Directories

Directories

If this preference is set to True (the default), ENVI will remember the last directory where you selected input files and will update the Input Directory preference accordingly. It will also remember the last directory where you saved any output files and will update the Output Directory preference. If you set this preference to False, the Input Directory and Output Directory preference values will be fixed.

Data Notation in Cursor Value

Display General

Set this preference to Float (the default) to report pixel values in floating-point decimals. Set it to Scientific to report pixel values in scientific notation.

Data Precision in Cursor Value

Display General

The number of decimal places of precision to report floating-point pixel values. The default value is 1. The maximum value is 10.

Reproject Multiple Rasters with Non-Standard Map Info

Display General

If you open two or more images with pseudo map information (or a combination of pseudo and RPC information), setting this preference to the default value of Yes automatically reprojects the images to a Geographic WGS-84 projection, or whatever base projection has already been established in the display. Opening two or more images with RPC map information reprojects the images to a UTM projection.

Create Pyramid if None Exists

Pyramid

Create and use pyramid files to speed up the display of large images. Disabling pyramid creation is only recommended for hyperspectral datasets since it may prohibit certain application functionality and reduce image display performance.

Programming


You can write event handlers to manage keyboard, mouse, and selection change events.

The ENVI API works with the new IDL implied print feature.

The ENVIView::HitTest function method returns an array of visualizations located at a mouse event or within a user-specified box.

The new ENVITask routine can create custom ENVI image processing tasks. For this release, the following tasks are available for use; more will be added in future releases.

The ENVICoordSys routine has new methods that convert between latitude/longitude, map, and MGRS coordinates.

The ENVIStandardRasterSpatialRef, ENVIRPCRasterSpatialRef, and ENVIPseudoRasterSpatialRef objects have new methods that convert between file, latitude/longitude, map, and MGRS coordinates.

The new ENVIGLTRasterSpatialRef routine supports geographic lookup table (GLT)-based spatial references.

The ENVIGCPSet routine defines or queries a set of ground control points.

The ENVI::GetOpenData method was deprecated in favor of the new ENVIDataCollection routine, which manages the contents of the Data Manager.

The ENVI::CreateRaster method was deprecated in favor of the ENVI::OpenRaster method, which can create new rasters from files or URIs.

The ENVI::CreateRasterMetadata method was deprecated in favor of the ENVIRasterMetadata routine, which now creates new metadata objects.

The ENVI::CreateRasterSpatialRef method was deprecated in favor of the ENVIPseudoRasterSpatialRef, ENVIRPCRasterSpatialRef, and ENVIStandardRasterSpatialRef routines, which now create spatial reference objects.

The ENVIRasterSpatialRefPseudo routine was deprecated and renamed to ENVIPseudoRasterSpatialRef.

The ENVIRasterSpatialRefRPC routine was deprecated and renamed to ENVIRPCRasterSpatialRef.

The ENVIRasterSpatialRefStandard routine was deprecated and renamed to ENVIStandardRasterSpatialRef.

The ENVI::ExportRaster method was deprecated in favor of the new ENVIRaster::Export method.

Other minor updates to API objects and methods are noted are in the Version History table of the relevant help topics.



Notes


This page has no user notes yet. Be the first one!


This information is not subject to the controls of the International Traffic in Arms Regulations (ITAR) or the Export Administration Regulations (EAR). However, it may be restricted from transfer to various embargoed countries under U.S. laws and regulations.
© 2014 Exelis Visual Information Solutions