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Using ASTER Data with FLAASH®
This tutorial describes how to prepare ASTER Level 1A data for input into Fast Line-of-sight
Atmospheric Analysis of Spectral Hypercubes (FLAASH). FLAASH is included in the Atmospheric
Correction Module: QUAC® and FLAASH®. You will import a sample ASTER Level 1A data set from
south-central Colorado into FLAASH and learn how to select appropriate parameters for FLAASH,
based on the characteristics of the scene.

Because ASTER Level 1A bands are not coregistered, you cannot directly input the VNIR or SWIR
data sets into FLAASH. This tutorial demonstrates how to georeference the data and how to use the
Layer Stacking tool to combine the visible near-infrared (VNIR) and shortwave infrared (SWIR) bands
into a single data set to input into FLAASH. If you only want to process one data set (for example,
VNIR only), you do not need to perform Layer Stacking.

Files Used in this Tutorial
Download data files from the Exelis website.

File Description
AST_LA.hdf ASTER Level 1A data set in HDF format, south-central Colorado
AST_L1A.hdf.met HDF global and local metadata for the above file

Introduction
FLAASH is a first-principles atmospheric correction modeling tool for retrieving spectral reflectance
from hyperspectral and multispectral radiance images. With FLAASH, you can accurately compensate
for atmospheric effects. FLAASH corrects wavelengths in the visible through near-infrared and short-
wave infrared regions, up to 2.5 μm. Unlike many other atmospheric correction programs that interpolate
radiation transfer properties from a pre-calculated database of modeling results, FLAASH incorporates
the MODTRAN4 radiation transfer code.

FLAASH also includes the following features:

l Correction for the adjacency effect (pixel mixing due to scattering of surface-reflected radiance)

l An option to compute a scene-average visibility (aerosol/haze amount). FLAASH uses the most
advanced techniques for handling particularly stressing atmospheric conditions, such as the
presence of clouds.

l Cirrus and opaque cloud classification map

l Adjustable spectral polishing for artifact suppression

FLAASH supports hyperspectral sensors (such as HyMAP, AVIRIS, HYDICE, HYPERION, Probe-1,
CASI, and AISA) and multispectral sensors (such as Landsat, SPOT, IRS, and ASTER). Water vapor
and aerosol retrieval are only possible when the image contains bands in appropriate wavelength
positions.
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In addition, FLAASH can correct images collected in either vertical (nadir) or slant-viewing geometries.
FLAASH was developed by Spectral Sciences, Inc.
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Prepare ASTER Data
1. From the ENVI® Classic main menu bar, select File > Open External File > EOS > ASTER.

The Enter ASTER Filenames dialog appears.

2. Select the file AST_L1A.hdf. Click Open. Four groups of data appear in the Available Bands
List: two groups of visible near-infrared (VNIR) data, one group of shortwave infrared (SWIR)
data, and one group of thermal infrared (TIR) data.

3. ENVI Classic automatically calibrates Level 1A data to radiance based on information on the
HDF attributes. The units of the output ASTER radiance are [W/(m2• sr • μm)].

Coregister Data
The Georeference ASTER tool is used to coregister the different ASTER bands, a step that is required
before the data can be atmospherically corrected using FLAASH.

Since the FLAASH model is only applicable to bands between 0.35 μm and 2.5 μm, do not use the TIR
bands. Also, In FLAASH, all of the bands that you simultaneously correct in the same input image must
have the same viewing geometry. Since Band 3B is a backward-viewing band, do not use this band.
(You can correct Band 3B separately in FLAASH if necessary.)

Page 4 of 14
© 2014 Exelis Visual Information Solutions, Inc. All Rights Reserved. This information is not subject to the controls
of the International Traffic in Arms Regulations (ITAR) or the Export Administration Regulations (EAR). However,
this information may be restricted from transfer to various embargoed countries under U.S. laws and regulations.



1. From the ENVI Classic main menu bar, select Map > Georeference ASTER > Georeference
Data. The Input ASTER Image dialog appears.

2. The Input ASTER Image dialog lists four files with the same name. Click the first file in the list;
this is the VNIR data set with three bands. Verify that the wavelengths range from 0.556 μm to
0.807 μm. Click OK. The Georeference ASTER Data dialog appears.

3. In the list of projections, select Geographic Lat/Lon. Accept the default values for the other
fields. You can select other projections, but you should use the same projection for the VNIR and
SWIR datasets. You are not required to enter an output GCP filename. If you want to keep your
GCPs, then you can enter a filename in the field provided.

4. Click OK. The Registration Parameters dialog appears.

5. Accept the default values for all fields, and choose Output Result to File.

6. In the Enter Output Filename field, type vnir_georef. Click OK. The Image Registration
status dialog appears during processing.

7. Repeat Steps 1-5 for the SWIR dataset. In the Input ASTER Image dialog, select the third AST_
L1A file in the list. (Verify the wavelengths range from 1.656 to 2.4 μm.) In the Registration
Parameters dialog, enter an output filename of swir_georef.

8. The georeferenced VNIR and SWIR bands now appear in the Available Bands List. Their band
names are preceded with "Warp."
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Combine VNIR and SWIR Data
The next step is to combine the georeferenced VNIR and SWIR datasets using the Layer Stacking tool,
and to resample the SWIR dataset to 15 m resolution to match the resolution of the VNIR dataset.

1. From the ENVI Classic main menu bar, select Basic Tools > Layer Stacking. The Layer
Stacking Parameters dialog appears.

2. Click Import File. The Layer Stacking Input File dialog appears.

3. Select vnir_georef and click OK.

4. Click Import File again. The Layer Stacking Input File dialog appears.

5. Select swir_georef and click OK.

6. Make sure vnir_georef is the top file. (Use the Reorder Files button and drag the filename
to the top, if necessary, to change the order).

7. Ensure that the Inclusive radio button is selected.

8. Ensure that the Output Map Projection is Geographic Lat/Lon.

9. Accept the default values for X/Y Pixel Size and Resampling.

10. In the Enter Output Filename field, type aster_vnir_swir, and click OK. After processing
is complete, the combined data set appears in the Available Bands List. Band names are preceded
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with "Layer."

Convert Interleave
FLAASH requires input files to be in BIL or BIP interleave.

1. From the ENVI Classic main menu bar, select Basic Tools > Convert Data (BSQ, BIL, BIP).
The Convert File Input File dialog appears.

2. Select the combined VNIR/SWIR dataset (aster_vnir_swir) and click OK. The Convert
File Parameters dialog appears.

3. Select the BIL radio button. Ensure the Convert In Place toggle button is set to No.

4. In the Enter Output Filename field, type aster_BIL and click OK. The ASTER data are now
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ready for input into FLAASH.
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Enter FLAASH Parameters
1. From the ENVI Classic main menu bar, select Spectral > FLAASH. The FLAASH Atmospheric

Correction Model Input Parameters dialog appears.

2. Click Input Radiance Image. The FLAASH Input File dialog appears.

3. Select aster_BIL and click OK. The Radiance Scale Factors dialog appears. The ASTER
radiance units are W/(m2 • μm • sr). FLAASH requires input radiance units of μW/( cm2 • nm •
sr).

4. Click Use single scale factor for all bands, and enter 10.0 for the Single scale factor. Click OK.

5. In the FLAASH dialog, click Output Reflectance File. The Select Output File dialog appears.
Navigate to a directory where you want to save the output reflectance file, and specify an output
filename. Click Open.

6. Click Output Directory for FLAASH Files. The Browse for Folder dialog appears. Navigate to
a directory where you want to save the output files. Click OK.

7. In the Rootname for FLAASH Files field, enter a prefix to add to each FLAASH file produced
during a single session. Do not include a directory path. The root name is the prefix appended to
the output FLAASH filenames. ENVI Classic automatically adds an underscore character to the
rootname.

Scene and Sensor Information
These fields help FLAASH determine where the sun was in the sky and the path of sunlight through the
atmosphere to the ground and back to the sensor.

1. Click the Sensor Type button and select Multispectral > ASTER. The Sensor Altitude (km)
value automatically changes to 705.000.

2. In the Pixel Size (m) field, enter 15.0.

3. The Ground Elevation (km) field is the average scene elevation in kilometers above sea level.
You would normally research this prior to entering scene and sensor information for FLAASH.
According to a DEM of this region, the average elevation is 2537 m (2.537 km). Enter a value of
2.537. If you are unsure of the values to enter for Scene Center Location, Flight Date, and
Flight Time GMT (if you are unfamiliar with the scene), you can locate them in the HDF
metadata that accompany the ASTER file.

4. From the ENVI Classic main menu bar, select Basic Tools > Preprocessing > Data-Specific
Utilities > View HDF Global Attributes. The Select Input HDF Filenames dialog appears.

5. Select AST_L1A.hdf. Click Open. The Global Attributes dialog appears. Note that the only
way to browse the metadata is to scroll; you cannot search for specific fields. Saving the
metadata to an ASCII file and opening it in a text editor will allow you to search specific field
names.
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6. From the Global Attributes dialog menu bar, select File > Save Text to ASCII. The Output
Report Filename dialog appears. Navigate to your output directory and select an output filename.
Click OK.

7. Close the Global Attributes dialog. Open the ASCII metadata file in a text editor.

8. Search for "SCENECENTER" in the metadata. The latitude of the scene center is 38.290529
degrees, and the longitude is -105.637035 degrees. In the FLAASH dialog, click the DD <->
DMS toggle button. Enter these values in the Lat and Lon fields of the FLAASH dialog,
respectively. Be sure to include the minus (-) sign to indicate the Western hemisphere.

9. Search for "SINGLEDATETIME" in the metadata. This field lists the day and time of data
acquisition for the data file. The date is 20000601, and the time of day is 181651033000Z. Enter
June 1, 2000 in the Flight Date field, and enter 18:16:51 GMT in the Flight Time GMT
(HH:MM:SS) field.

Select Atmospheric Model Settings
Use the Atmospheric Model drop-down list to choose one of the standard MODTRAN model
atmospheres. For the best results, select a model whose standard column water vapor amount is similar
to, or somewhat greater than, that expected for the scene. The following table lists the standard column
water vapor amounts (from sea level to space) for each model atmosphere.
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Model Atmosphere Water Vapor
(std atm-cm)

Water Vapor
(g/cm2) Surface Air Temperature

Sub-Arctic Winter (SAW) 518 0.42 -16° C or 3° F
Mid-Latitude Winter (MLW) 1060 0.85 -1° C or 30° F
U.S. Standard (US) 1762 1.42 15° C or 59° F
Sub-Arctic Summer (SAS) 2589 2.08 14° C or 57° F
Mid-Latitude Summer (MLS) 3636 2.92 21° C or 70° F
Tropical (T) 5119 4.11 27° C or 80° F

1. The ASTER scene used in this tutorial is in south-central Colorado, so select U.S. Standard from
the Atmospheric Model drop-down list.

2. The Water Retrieval toggle button is greyed out because this is not an option with ASTER data.
You will use a constant column water vapor amount for all pixels in the image. Leave the default
value of 1.0 in the Water Column Multiplier field.

Select Aerosol Model Settings
The Aerosol Model drop-down list has the following options. The choice of model is not critical if the
visibility is high (for example, greater than 40 km).

l Rural: Represents aerosols in areas not strongly affected by urban or industrial sources. The
particle sizes are a blend of two distributions: one large and one small.

l Urban: A mixture of 80% rural aerosol with 20% soot-like aerosols, appropriate for high-density
urban/industrial areas.

l Maritime: Represents the boundary layer over oceans, or continents under a prevailing wind from
the ocean. It is composed of two components, one from sea spray and another from rural
continental aerosol (that omits the largest particles).

l Tropospheric: Applies to calm, clear (visibility greater than 40 km) conditions over land and
consists of the small-particle component of the rural model.

1. From the Aerosol Model drop-down list, select Rural. This particular ASTER scene is centered
in a mountainous area that is not strongly affected by urban or industrial sources.

2. From the Aerosol Retrieval drop-down list, select None. It is not recommended to retrieve the
visibility (aerosol) with ASTER data. While ASTER bands cover the region required for the dark-
land pixel-retrieval method, the bandwidth for Band 2 is fairly wide (60 nm) and will likely
include the vegetation red edge, which could significantly bias the visibility estimate.

3. The Initial Visibility (km) value is assumed for the atmospheric correction if the aerosol is not
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being retrieved. The following table lists approximate values based on weather conditions:

Weather Condition Scene Visibility
Clear 40 to 100 km
Moderate Haze 20 to 30 km
Thick Haze 15 km or less

Leave the default value of 40.00 for Initial Visibility (km).

Run FLAASH
The FLAASH Atmospheric Correction Model Input Parameters dialog should similar to the following:

1. The Multispectral Settings button is only used to select specific bands for water and aerosol
retrieval. Since you are not retrieving any of these with ASTER data, you do not need to click
Multispectral Settings.

2. For this tutorial, you will not use the Advanced Settings, Save, or Restore buttons.
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3. In the FLAASH Atmospheric Model Input Parameters dialog, click Apply to begin the FLAASH
processing. You may cancel the processing at any point, but be aware that there are some
FLAASH processing steps that cannot be interrupted, so the response to the Cancel button may
not be immediate. When FLAASH processing is complete, the output reflectance image appears
in the Available Bands List. You should also find the journal file and the template file in the
FLAASH output directory.

4. Click Cancel in the FLAASH Atmospheric Correction Model Input Parameters dialog.

5. Examine and close the FLAASH Atmospheric Correction Results dialog.

Copyright Notice:

ENVI Classic is a registered trademark of Exelis Inc.

QUAC and FLAASH are registered trademarks of Spectral Sciences, Inc.
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