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Working with NITF Data
This tutorial introduces common tasks when working with National Imagery Transmission Format
(NITF) files. The first exercise shows you how to open a NITF 2.1 multiple image segment file; how to
view metadata, Tagged Record Extensions (TREs), and Data Extension Segments (DESes); how to chip
(subset) the file; and how to save the chip to NITF format. The second exercise demonstrates the use of
rapid positioning coordinate (RPC) map information in georeferencing a NITF file. The third exercise
explains how to work with composite images and how to edit Profile for Imagery Access (PIA) TREs.

Files Used in this Tutorial
Download data files from the Exelis website.

File Description
digitalglobe_ncdrd_chip.ntf NITF 2.1 Quickbird image of St. Petersburg, Russia
target_example.ntf NITF 2.1 composite image

The QuickBird file digitalglobe_ncdrd_chip.ntf is courtesy of DigitalGlobe and may not be
reproduced without explicit permission from DigitalGlobe. The file target_example.nitf was
provided by the Joint Interoperability Test Command (JITC) for test purposes.
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Exercise 1: Metadata, TREs, DESes, Chipping,
and Saving
In this exercise, you will open a NITF 2.1 file; view metadata, TREs, and DESes; chip (subset) the file;
and save multiple image segments to NITF format.

1. From the ENVI® Classic main menu bar, select File > Open Image File. The Enter Data
Filenames dialog appears.

2. Select the file digitalglobe_ncdrd_chip.ntf, and click Open. The file appears in the
Available Bands List as two image segments. Image segment #1 is a QuickBird image of St.
Petersburg, Russia, and image segment #2 is an NCDRD cloud image.

3. In the Available Bands List, right-click on the filename digitalglobe_ncdrd_chip.ntf,
and select Load True Color. An RGB version of image segment #1 is loaded into a new display
group.

Viewing Metadata
1. In the Available Bands List, right-click on the filename digitalglobe_ncdrd_chip.ntf

and select View NITF Metadata. The NITF Metadata Viewer dialog appears. The metadata for
this file is organized into separate entries for the file header, image segments, a text segment, and
Data Extension Segments (DESes). Header and segment fields are described in more detail in the
MIL-STD-2500A and MIL-STD-2500C specifications.

2. In the NITF Metadata Viewer, click the + symbol next to NITF file header to see metadata
describing the file properties.
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3. Click the + symbol next to Image segment #1 and Image segment #2 to see metadata describing
the image characteristics. Image segments contain raster image data, intended for display or
analysis. Under image segment #2, notice that the Image Representation field contains the value
“NODISPLY.” This means the image segment will not be chipped if you save it to NITF format.

Viewing a Text Segment
This file contains a text segment, which consists of textual information not intended for graphical
display. Most of the time, text segments are provided to supplement the graphic content in the dataset.

1. In the NITF metadata viewer, click the + symbol next to Text segment #1.

2. Click on the line that says Text: <Click to view>. A Text dialog appears with the information
contained within the text segment subheader. In this case, the text segment contains the end-user
license agreement from DigitalGlobe.

3. Close the Text dialog.

Tagged Record Extensions
When you click the + symbols to expand the file header, image segments, and DESes in the NITF
Metadata Viewer, you will notice various colored icons that say “TRE.” These are tagged record
extensions, which contain information about the segment they are in. The file header can contain one or
more TREs that apply to the entire data set, and each segment (image, text, annotation) can also have
one or more TREs associated with it. TREs can specify attributes such as processing history,
information about specific targets in an image, collection information, and other types of metadata.

A white TRE icon contains metadata for a TRE that you cannot edit when saving the file. A green icon
contains metadata that you can edit when saving the file.

Each TRE supported by the NITF/NSIF Module references an XML definition file that is installed with
your ENVI Classic software if you purchased the NITF/NSIF Module.

The following figure shows the TREs for Image Segment #1.

When working with NITF data outside of this tutorial, your data may contain some TREs that do not
have an associated XML file. These TREs are displayed with a “Definition Unknown” label next to
their name. Their contents may be viewable if the TREs do not contain binary data. ENVI Classic will
save these TREs.
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Data Extension Segments
In the NITF Metadata Viewer, you will also see two blue icons that say “DES.” These are data
extension segments, which are similar to TREs because they contain information that cannot be stored in
other NITF segments.

The file you are working with is a NITF 2.1 Commercial Dataset Requirements Document (NCDRD)
file that contains two shapefile DESes indicated by the word “CSSHPA.”

1. Click on the + symbol next to DES #1: CSSHPA DES to view its metadata. Then click the +
symbol next to User Defined Subheaders. You will see that this is a CLOUD_SHAPES DES,
which is a polygon shapefile containing cloud locations.

2. In the NITF Metadata Viewer, click Load DES Shapefiles. This button is only available when
you open NCDRD files with at least one CSSHPA DES. ENVI Classic extracts the
corresponding shapefile element, converts it to ENVI vector format (EVF), and loads it into the
Available Vectors List.

3. In the Available Vectors List, select the layer named digitalglobe_ncdrd_chip_CLOUD_
SHAPES, and click Load Selected. The Load Vectors dialog appears.

4. Select Display #1, and click OK. Polygon vectors overlay the image segment in the display group,
roughly outlinining the boundaries of clouds. The Vector Parameters dialog also appears.
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5. Use the Vector Parameters dialog to change the color of the vector layer to another color.

6. In the NITF Metadata Viewer, click on the + symbol next to DES #2: CSSHPA DES to view its
metadata. Then click the + symbol next to User Defined Subheaders. You will see that this is an
IMAGE_SHAPE DES, which is a single-polygon shapefile defining the original image extent.

7. When you are finished, close the Available Vectors List, Vector Parameters, and NITF Metadata
Viewer dialogs. The vector shapefiles disappear from the display group. (If you want to view
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them again in the future, you can select Vector > Available Vectors List from the ENVI Classic
main menu bar, then load the desired vectors to the display group.)

Chipping the Image and Saving to NITF Format
In these steps, you will attempt to chip (subset) both image segments and output them to NITF format.

1. From the ENVI Classic main menu bar, select File > Save File As > NITF. The Select NITF
Output File dialog appears. The left side of the dialog lists both image segments associated with
the file.

2. Select the image segment named digitalglobe_ncdrd_chip.ntf M1043BFF00.
Information about the file is displayed, along with Spatial Subset and Spectral Subset buttons and
an All Image Segments check box.

3. Click to enable the All Image Segments check box to select both image segments for saving.
Special rules apply when saving any NITF image with multiple image segments:

l You can save one or all of the image segments to an output NITF file. If you have three
or more image segments, you cannot use Ctrl-click to select multiple image segments.
If you hold down the Shift key and select another segment, the last segment you
selected is highlighted (not all segments).

l You cannot create a NITF file with multiple image segments if the input file does not
contain multiple image segments.

l The Spectral Subset button is not available if all segments are selected.

l If you select all image segments and uncheck All Image Segments, the previously
selected image segment is selected.

l You can edit multiple image segment metadata the same was as single-image output.

l You cannot save image segments containing masks to an output NITF file.

l You cannot change the NITF file version or compression parameters when saving
multiple image segments.

4. Click Spatial Subset. The Select Spatial Subset dialog appears.

5. Click Image. The Subset by Image dialog appears.

6. Leave the Samples and Lines values at 400, and move the red box to any location within the
image. Click OK.

7. Click OK on the Select Spatial Subset dialog and the Select NITF Output File dialog. The NITF
Output Parameters dialog appears.

8. Select an output filename and click OK. After processing is complete, the output file (and its
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associated image segments) are added to the Available Bands List.

Examining the Output
1. In the Available Bands List, right-click on Image Segment #2 of your chipped image and select

Load Band to New Display. Note that image segment #2 (the NCDRD cloud image) was not
chipped upon output because the Image Representation metadata value was “NODISPLY” (in the
original image).

2. Close Display #2 (containing Image Segment #2).

3. In the Available Bands List, right-click on the new filename and click Load True Color to
<new>. In the next step, you will use ENVI’s Dynamic Overlay feature to compare the original
(unchipped) image in Display #1 to the chipped image in Display #2.

4. From any display group menu bar, select Tools > Link > Link Displays. The Link Displays
dialog appears.

5. Ensure that the Display #1 and Display #2 toggle buttons are both set to Yes. Also ensure the
Dynamic Overlay toggle button is set to On. Click OK.

6. Click in one of the Image windows to toggle between the original (unchipped) image and the
chipped image. Notice the color differences between the two images. ENVI Classic
automatically assigned a default 2% linear stretch to the unchipped image, but not to the chipped
image that you saved.

Viewing the Output Metadata
1. In the Available Bands List, right-click on the new filename, and select View NITF Metadata.

The NITF Metadata Viewer dialog appears.

2. Browse through the metadata and notice that ENVI Classic retained the input metadata, TREs,
and DESes. An exception is that some fields in the image and file header metadata were updated
to indicate processing changes to the file upon chipping. Also notice that ENVI Classic added an
ICHIPB TRE to Image Segment #1, which indicates the image was chipped.
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If you click the + symbol to expand the NITF file header metadata, you will see the Originating
Station ID, Originator’s Name, and Originator’s Phone fields were changed to the defaults set in
the NITF configuration file.

On Windows, the NITF configuration file is located in C:\Program
Files\Exelis\IDLxx\products\envixx\menu\nitf.cfg.

On Unix, the file is located in
/usr/local/exelis/idlxx/products/envixx/menu/nitf.cfg.

3. Click Load DES Shapefiles.

4. In the Available Vectors List, select the CLOUD_SHAPES layer corresponding to the output file
you created. Click Load Selected. The Load Vectors dialog appears.

5. Select New Vector Window, and click OK. Note the full extent of the DES shapefile. It was not
chipped upon output.

6. When you are finished, close all dialogs and display groups except for the Available Bands List
and NITF Metadata Viewer. You will use the same data file for the next exercise.
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Exercise 2: RPC Map Information
In this exercise, you will learn how the NITF/NSIF Module uses RPC map information to georeference
a file. You will open the file digitalglobe_ncdrd_chip.ntf (which contains RPC map
information) and view the map information used for georeferencing.

The NITF/NSIF Module uses a variety of different map information for georeferencing:

l Replacement sensor model (RSM) TREs

l Rapid positioning capability (RPC) TREs

l DIGEST GeoSDE TREs (MAPLOB, PRJPSB, and GEOPSB TREs)

l IGEOLO image header field

If a NITF file contains RPC or RSM map information, the NITF/NSIF Module in ENVI Classic uses
that information to georeference the file. If a file does not contain RPCs or RSMs, ENVI Classic looks
for the items in the above list (in that order) to georeference the file. This exercise focuses on the use of
RPCs only.

For a full discussion on how ENVI Classic uses non-standard projections such as affine map
transformations, RPCs, and RSMs, see the ENVI Classic Help.

Background on Sensor Models
Sensor models are a type of map information used to define the physical relationship between image
coordinates and ground coordinates. A sensor model is a mathematical model that replaces the rigorous
(physical) sensor model associated with a specific sensor by representing the model’s ground-to-image
relationship. It is used to map a 3D ground point to a 2D image point. Various commercial spaceborne
image providers utilize replacement sensor models, particularly RPCs, which are one type. Two sensor
models that ENVI Classic uses are RPCs and RSMs. This tutorial only discusses the use of RPCs.

RPCs
Rational polynomial coefficients (RPCs) are one type of sensor model. RPCs are not the same as a map
projection; rather, they model the ground-to-image relationship as a third-order, rational, ground-to-image
polynomial. You can use RPCs to perform orthorectification and DEM extraction in ENVI Classic.

QuickBird data include pre-computed RPCs with the imagery. If your file has RPC information, you can
automatically derive RPC-based geolocation information for individual pixels in an image. This method
is not as geographically accurate as performing a full orthorectification, but it is less computationally and
disk-space intensive.

If your image file has pre-computed RPC information, ENVI Classic uses the mean elevation value used
in the RPC transformation for the entire image. However, you can significantly increase the geolocation
accuracy of the image if you associate the image with a DEM.
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The NITF/NSIF Module reads RPC information from a NITF file and creates an RPC00A or RPC00B
TRE. If either of these TREs exists in a NITF file, ENVI Classic uses the RPC model to emulate a
projection by default. The projection description includes the string *RPC* prior to the name of the
coordinate system in which the image resides.

Viewing Map Information
1. In the NITF Metadata Viewer dialog, click the + symbol next to Image segment #1

(digitalglobe_ncdrd_chip.ntf) to expand its contents.

2. Scroll until you see the RPC00B TRE. Click the + symbol next to this TRE to expand its contents.
All of the information here was derived from the RPC map information provided with the
QuickBird image of St. Petersburg. ENVI Classic had read this information into an RPC00B TRE
and georeferenced the file using the coefficients shown here.

3. Click Cancel in the NITF Metadata Viewer dialog.

4. In the Available Bands List, you should see a Map Information icon under digitalglobe_
ncdrd_chip.ntf. This indicates that the file is georeferenced. Click the + symbol to expand
its contents. The Proj field shows that RPCs are used to emulate a Geographic Lat/Lon projection.

5. In the Available Bands List, right-click on digitalglobe_ncdrd_chip.ntf, and select
Load True Color.

6. Double-click in the Image window to display the Cursor Location/Value tool.

7. Move around the image and note how ENVI Classic displays geographic latitude and longitude
coordinates. Also note that the Cursor Location/Value tool shows the Projection as *RPC*
Geographic Lat/Lon.

8. When you are finished, select File > Close All Files from the ENVI Classic main menu bar, then
click Yes to close all files.
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Exercise 3: Viewing Composite Images and Editing
PIA TREs
In this exercise, you will learn about composite images and how to edit Profile for Imagery Access
(PIA) TREs when saving a NITF file.

1. From the ENVI Classic main menu bar, select File > Open Image File. The Enter Data
Filenames dialog appears.

2. Select the file target_example.ntf, and click Open. This is a composite image consisting
of two image segments and various annotation segments. The first entry that appears in the
Available Bands List is the RGB composite image. The next two entries are the image segments
that make up the composite image.

3. Click Load RGB. The composite image is loaded to a new display group.

4. In the Available Bands List, right-click on Image Segment #1 and select Load Band to New
Display. The first image segment appears in a new display group.

5. Double-click inside the Image Window in Display #1 (composite image). The Cursor
Location/Value dialog displays. Move your cursor around the composite image, then around the
corresponding image segment (for the same location). Note that the composite image does not
display geographic information, but the image segment does. The composite image is simply a
graphical depiction of the individual image and annotation segments, but it does not provide map
information.

Saving to NITF Format
1. From the ENVI Classic main menu bar, select File > Save File As > NITF. The Select NITF

Output File dialog appears.

2. Select the COMPOSITE image for output. Notice that all of the image segments are selected for
output when you select the composite image. The All Image Segments check box is also
automatically checked.

3. Click OK. The NITF Output Parameters dialog appears.

4. Click Edit NITF Metadata. The NITF Metadata Editor dialog appears.

Adding PIA TREs
The NITF Metadata Editor lets you add or delete Profile for Imagery Access and Profile for Imagery
Archive (PIA) TREs, which hold information required by the Standards Profile for Imagery Access
(SPIA). A variety of government agencies require these TREs in NITF image products. In this step, you
will simulate adding a Profile for Imagery Access Target Descriptive (PIATGB) TRE to mark a target
of interest in the data.
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1. In the NITF Metadata Editor, select Image segment #1 and click Add PIA Tags. The Add PIA
Tags dialog appears.

2. Change the value for PIATGB (PIA Target Tag) to 1.

3. Click OK. The metadata under Image segment #1 expands in the NITF Metadata Editor. A new
green TRE symbol appears at the bottom of the metadata.

4. Click the + symbol to expand the new TRE.

5. Double-click on any of the empty fields such as Target UTM. A text entry dialog appears.

6. Enter your own text and click OK. A text entry dialog for the next PIATGB TRE metadata field
appears.

7. Continue adding your own values for the PIATGB TRE metadata in this manner.
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8. Click OK in the NITF Metadata Editor. ENVI Classic validates your entry and issues an error
message if you entered incorrect data.

9. In the NITF Output Parameters dialog, enter an output filename, and click OK.

10. When the output file appears in the Available Bands List, right-click on its filename and select
View NITF Metadata.

11. Examine the metadata in the output file. You should see the new PIATGB TRE metadata.

Copyright Notice:

ENVI Classic is a registered trademark of Exelis Inc.

QUAC and FLAASH are registered trademarks of Spectral Sciences, Inc.
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