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Target Detection
This tutorial provides an introduction to the ENVI® Classic Target Detection Wizard. The Target
Detection Wizard guides you through the process of finding targets in hyperspectral or multispectral
imagery. The targets may be a material or mineral of interest, or they may be man-made objects.

This tutorial will have you find a target in the imagery that is composed of red cotton fabric.

Files Used in this Tutorial
Download data files from the Exelis website.

File Description
self_test_rad.img Hyperspectral radiance scene
self_test_rad.hdr Header file for above
self_test_refl.img Hyperspectral reflectance scene
self_test_refl.hdr Header file for above
F1.roi Region of interest (ROI) file for red cotton fabric
F1_l.spl Lab Spectra ENVI Classic Spectral Library for red cotton fabric
F1_l.hdr Lab Spectra header file for above

The Resources directory contains sample output files from the Mixture Tuned Matched Filtering
(MTMF) (self_test_1*.*) and Adaptive Coherence Estimator (ACE) (self_test_2*.*)
target detection methods, using the same settings described in this tutorial.
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Using the Target Detection Wizard
From the ENVI Classic main menu bar, select Spectral > Target Detection Wizard. The Target
Detection Wizard dialog appears.

A brief description of the Wizard follows.

l The Introduction panel explains the overall workflow of the Wizard. The remaining panels in the
Wizard describe each step of this process.

l The left panel in the Wizard shows a brief description of each step. The right panel contains the
interface for that step.

l You can hide the left panel by clicking Hide Text. If the left panel is hidden, click Show Text to
re-display it.

l Each panel contains a Next button for continuing to the next step and a Prev button for reverting
to the previous step. Next is only enabled if you provide enough information to continue in the
workflow. In some cases, a processing status dialog appears before the next panel is initialized.
You can also use the Next and Prev buttons to loop back through the Wizard and repeat a series
of steps.

Click Next in the wizard to proceed.
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Target Detection Analysis Using the MTMF Method
In this section, you will run target detection using the Mixture Tuned Matched Filtering (MTMF)
method. MTMF uses an MNF transform input file to perform Matched Filtering (MF), and it adds an
infeasibility image to the results. The infeasibility image is used to reduce the number of false positives
that are sometimes found when using MF alone. Pixels with a high infeasibility are likely to be MF false
positives. Correctly mapped pixels will have an MF score above the background distribution around zero
and a low infeasibility value. The infeasibility values are in noise sigma units that vary in Digital
Number (DN) scale with an MF score.

Selecting the Input/Output Files
In Step 1 of the wizard, select the input file to use for target detection and provide a root name for all
target detection output files.

1. Click Select Input File. The Target Detection Wizard Input File dialog appears.

2. Click Open and select New File. The Please Select a File dialog appears.

3. Select self_test_rad.img and click Open.

4. In the Target Detection Wizard Input File dialog, click OK.

5. Click Select Output Root Name. The Select Output Root Name dialog appears.

6. Enter the root name td_mtmf_out to use for all target detection output files, then click Open.

7. Click Next to proceed to the Atmospheric Correction panel (Step 2).

8. Since you will use a region of interest as target spectra in this analysis, you will skip atmospheric
correction. Click Next again to proceed to the Select Target Spectra panel.

Selecting Target Spectra to Include in Processing
In Step 3 of the Target Detection Wizard, select the spectra to use as the desired target signatures in the
target detection analysis. You will select the spectra from spectral libraries.

1. In the Select Target Spectra panel, click Import and select from ROI/EVF from input file. The
Enter ROI/EVF Filenames dialog appears.
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2. Select F1.roi.

3. Click Open. The Select Regions for Stats Calculation dialog appears.

4. Select the spectrum Site 12 – Full (Red) 1 points, then click OK. The spectrum is added to the
Select Target Spectra panel.

5. Click Next in the Wizard. The Select Non-Target Spectra panel appears (Step 4).

6. You will not be including non-target spectra in this analysis, so click Next again. The Apply MNF
Transform panel appears.

Applying the MNF Transform before Processing
In Step 5 of the Target Detection Wizard, perform a Minimum Noise Fraction (MNF) transform on the
input image. ENVI Classic uses the MNF transform to segregate and equalize the noise in the data, and
to reduce the data dimensionality for target detection processing. The resulting bands of the MNF
transformed data are sorted by spatial coherence in descending order. Lower MNF bands typically have
spatial structure and contain most of the information. Higher MNF bands typically have little spatial
structure and contain most of the noise.

For more detailed information, see the ENVI Classic Help.

1. To apply the MNF transform, leave the Apply MNF Transform? toggle at Yes.

2. Click Next in the Wizard. The Target Detection Methods panel appears.

Selecting the Target Detection Method
In Step 6 of the Target Detection Wizard, select the method to use to find the spatial location of each of
the selected targets.

1. Select the Mixture Tuned Matched Filtering (MTMF) method for target detection.

2. Click Next in the Wizard. The Load Rule Images and Preview panel appears.

Loading and Examining the Resulting Rule Images
In Step 7 of the Target Detection Wizard, load the rule images that ENVI Classic created during target
detection processing.

The rule image is listed in the Target and Method columns and is automatically loaded into a display
group. A Square Root stretch is applied. Binary Preview mode is automatically enabled, and you should
see detected target pixels highlighted in the color you specified in Step 3 (Select Target Spectra). The
Target Pixel Count tells you how many pixels ENVI Classic found that matched your target spectra.

Because you selected the MTMF analysis, a 2D Full Band Scatter Plot is also open.
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In the 2D Full Band Scatter Plot, a good region to visualize is one defined by high detection scores and
low infeasibility values.

The Full Band 2D Scatter Plot view is constructed from the entire band, not just the data visible in the
Image window. When the view in the Image window changes, the view in the Full Band Scatter Plot
does not. When you select different regions in the Full Band Scatter Plot, the highlighted pixels in the
Image, Scroll, and Zoom windows update.

Dancing pixels, density slice, and menus are not available. Use the following mouse buttons in the 2D
plot:

l Draw polygons using the left mouse button. Left-click in the scatter plot to define the vertices of a
new polygon that will select pixels. Right-click to close the polygon.

l Clicking the middle mouse button before you close the polygon erases it.

l Resize the scatter plot using the middle mouse button. Click the middle mouse button, grab the
corner of the window and drag to the desired size. To reset the plot to its default size, middle-
click anywhere on the plot.
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l Resizing the scatter plot causes any drawn polygon(s) to be reset.

l Erase all drawn polygons by clicking the middle mouse button outside of the scatter plot.

1. When you have finished previewing the output image and plot, click Next. The Target Filtering
panel appears (Step 8).

2. Accept the default settings by clicking Next. The Apply MNF Transform panel appears.

Exporting the Result to Shapefiles and ROIs
In Step 9 of the Target Detection Wizard, select to export the target detection results to one shapefile
and one ROI for the MTMF target detection method.

1. Enable the ROI, Shapefile, and Display ROI check boxes.

2. Click Next. The View Statistics and Report panel displays.

For shapefile output, ENVI Classic performs raster-to-vector conversion for each of the selected
target detection methods and lists the output in the Available Vectors List.
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The ROI Tools dialog appears. Use the ROI Tools dialog to find the MTMF ROIs.

Viewing the Processing Statistics and Summary Report
In Step 10 of the Target Detection Wizard, the Statistics tab shows statistics for each of the selected
target detection methods. Statistics are available because you exported an ROI and a shapefile in the
previous step. To save the summary report, click Save Target Detection Summary and enter a
filename and path in the Output Report Filename dialog that appears.

The Report tab shows a summary of the setup you used to generate the target detection results.

Click Finish to close the Target Detection Wizard.
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Select File > Close All Files to close all open files and prepare for the next analysis.
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Target Detection Analysis Using the ACE Method
In this section, you will run target detection using the Adaptive Coherence Estimator (ACE) method
Derived from the Generalized Likelihood Ratio (GLR) approach, ACE is invariant to relative scaling of
input spectra and has a Constant False Alarm Rate (CFAR) with respect to such scaling. ACE does not
require knowledge of all the endmembers within a scene.

Selecting Input/Output Files
In Step 1 of the wizard, select the input file to use for target detection and provide a root name for all
target detection output files.

1. Click Select Input File. The Target Detection Wizard Input File dialog appears.

2. Click Open and select New File. The Please Select a File dialog appears.

3. Select self_test_rad.img and click Open.

4. In the Target Detection Wizard Input File dialog, click OK.

5. Click Select Output Root Name. The Select Output Root Name dialog appears.

6. Enter the root name td_ace_out to use for all target detection output files, then click Open.

7. Click Next to proceed to the Atmospheric Correction panel.

Applying Atmospheric Correction
In Step 2 of the wizard, perform atmospheric correction on the input image.

1. Select QUick Atmospheric Correction (QUAC) as the atmospheric correction method (requires
a licensed installation of the Atmospheric Correction Module).

QUAC determines the atmospheric compensation parameters directly from the information
contained within the scene using the observed pixel spectra. This method assumes that the
average reflectance of a collection of diverse material spectra, such as the endmember spectra in
a scene, is effectively scene-independent. This enables the retrieval of reasonably accurate
reflectance spectra, even with radiometrically uncalibrated data.
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Note: If you do not have an Atmospheric Correction Module license, select another atmospheric
correction method.

2. If you selected QUick Atmospheric Correction as the correction type, change the value in the
Sensor Type field to HyMap.

3. Click Next to proceed to the Select Target Spectra panel.

Compare QUAC Output to the Reflectance Image
Before you select target spectra, compare the QUAC output with the reflectance image to see how well
the atmospheric correction performed.

1. In the Available Bands List, select File > Open Image File. The Enter Data Filenames dialog
appears.

2. Select self_test_refl.img and click Open.

3. Right-click on the filename and select Load True Color.

4. In the Available Bands List, scroll to the td_ace_out_quac file.

5. Right-click on the filename and select Load True Color to <new>.

6. Compare the two displays. From the Display group menu bar, select Tools > Link > Link
Displays.

7. In the Link Displays dialog, click OK.

8. Right-click in the first Display group and select Z Profile (Spectrum).

9. Right-click in the second Display group and select Z Profile (Spectrum). The shape of the two
profiles should be very similar.
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Selecting Target Spectra to Include in Processing
In Step 3 of the Target Detection Wizard, select the spectra to use as the desired target signatures in the
target detection analysis. You will select the spectra from spectral libraries.

1. In the Select Target Spectra panel, click Import and select from Spectral Library file. The
Spectral Library Input File dialog appears.

2. Click Open and select New File. The Please Select a File dialog appears.

3. Select F1_l.spl.

4. Click Open. The Input Spectral Library File dialog appears.

5. Select the spectrum, then click OK. The spectrum is added to the Select Target Spectra panel as
SPEX_Cloth_Red.csv:C2.

6. Right-click in the Color field and select Colors 1-20 > Red.

7. Select the spectrum in the list.

8. Click Next in the Wizard. The Select Non-Target Spectra panel appears (Step 4).

9. You will not be including non-target spectra in this analysis, so click Next again. The Apply MNF
Transform panel appears (Step 5).

10. You will not be applying the MNF transform in this analysis. Change the Apply MNF
Transform? toggle to No, then click Next. The Select Target Detection Methods panel appears.

Selecting the Target Detection Method
In Step 6 of the Target Detection Wizard, select the method to use to find the spatial location of each of
the selected targets.

1. Select the Adaptive Coherence Estimator (ACE) method for target detection.

2. Click Next in the Wizard. The Load Rule Images and Preview panel appears.
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Loading and Examining the Resulting Rule Images
In Step 7 of the Target Detection Wizard, load the rule images that ENVI Classic created during target
detection processing.

The rule image is listed in the Target and Method columns and is automatically loaded into a display
group. A Square Root stretch is applied. Binary Preview mode is automatically enabled, and you
should see detected target pixels highlighted in the color you specified in Step 3 (Select Target Spectra).
The Target Pixel Count tells you how many pixels ENVI Classic found that matched your target
spectra.
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To further refine the display, you can do the following:

l To apply a different stretch to the display, select from the Default Stretch drop-down list. Square
Root is typically a good stretch when the target pixels occupy a small population of the image.

l For ACE, ENVI Classic uses a default thresholding value. To apply a different Rule Threshold,
move the slider or enter a new value. The target pixels are highlighted in the display group. Adjust
the threshold to a higher value to select fewer pixels, and vice versa.

l Threshold settings behave in the opposite manner for SAM since lower values represent a high
probability of being a target in the SAM rule image.

1. When you have finished previewing the output image and plot, click Next. The Target Filtering
panel appears (Step 8).

2. Accept the default settings by clicking Next. The Apply MNF Transform panel appears.
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Exporting the Result to Shapefiles and ROIs
In Step 9 of the Target Detection Wizard, select to export the target detection results to one shapefile
and one ROI for the ACE target detection method.

1. Enable the ROI, Shapefile, and Display ROI check boxes.

2. Click Next. The View Statistics and Report panel displays.

For shapefile output, ENVI Classic performs raster-to-vector conversion for each of the selected
target detection methods and lists the output in the Available Vectors List.

The ROI Tools dialog appears. Use the ROI Tools dialog to find the ACE ROIs.

Viewing the Processing Statistics and Summary Report
In Step 10 of the Target Detection Wizard, the Statistics tab shows statistics for each of the selected
target detection methods. Statistics are available because you exported an ROI and a shapefile in the
previous step. To save the summary report, click Save Target Detection Summary and enter a
filename and path in the Output Report Filename dialog that appears.
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The Report tab shows a summary of the setup you used to generate the target detection results.

Click Finish to close the Target Detection Wizard.

You can quit your ENVI Classic session by selecting File > Exit from the ENVI Classic main menu bar.

Copyright Notice:

ENVI Classic is a registered trademark of Exelis Inc.

QUAC and FLAASH are registered trademarks of Spectral Sciences, Inc.
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