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A Quick Start to ENVI

This Quick Start tutorial is aimed at providing a newer ENVI user with a brief introduction to the
graphical user interface and basic capabilities of ENVI.

Files Used in this Tutorial
ENVI Resource DVD: Data\can_tm

File Description
can_tmr.img [ Cafion City, CO, TM Data
can_tmr.hdr | ENVI header for above
can_vl.evEf |ENVI vector file 1
can_v2.evi | ENVI vector file 2
can_v3.evf | ENVI vector file 3
can_v4.evE [ENVI vector file 4




@ENV| ENVI Tutorial: A Quick Startto ENVI

Getting Started with ENVI

Before attempting to start the program, ensure that ENVTI is properly installed as described in the
Installation Guide that shipped with your software.

Starting ENVI

Windows:
Select Start > Programs > ENVI x.x > ENVI. (where x.x is the ENVI version number)
Unix:

For ENVI, enter envi rt atthe UNIX command line. For ENVI+IDL, enter envi at the UNIX
command line.

Macintosh:

First, display an OSX, UNIX X-window. For ENVI, type envi rt at the UNIX command prompt. For
ENVI +IDL, type envi at the UNIX command prompt.

Loading a Gray Scale Image

Open a multispectral Landsat Thematic Mapper (TM) data file representing Cafion City, Colorado,
USA.

Opening an Image File
1. From the ENVI main menu bar, select File > Open Image File.

2. Navigate to the Data\can_tm directory, select the file can_tmr . img from the list, and click
Open.

The Available Bands List dialog appears on your screen. This list allows you to select spectral
bands for display and processing. You have the choice of loading either a grayscale or an RGB
color image.

& Available Bands List  [2 (B

Fila Optiors

= [l contmvimg
TH Band 1 [0L4550)
TH Band 2 [0L5E00]
o TM Band 3 [IUEED0)
o TM Band 5 [1.6500)
o TH Band 7 [2.2150)

% Geay Scale  RGE Color

Selacted Band
{TM Band 4 (08300} can_tr img

|I2Im-z £40 % 400 [Byte] (B50] |

| Load Band | Mo Display v“

3. Select TM Band 4. The band you have chosen is displayed in the field marked Selected Band.
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4. Click the Gray Scale radio button then click Load Band to load the image into a new display.
Band 4 will be loaded as a gray scale image.
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Familiarizing Yourself with the ENVI Interface

When the image loads, an ENVI image display appears on your screen. The display group consists of an
Image window, a Scroll window, and a Zoom window. These three windows are intimately linked;

changes to one window are mirrored in the others.

Image \Window

Scroll Window: Foorr Windoy

Y ou can choose which combinations of windows appear on the screen by right-clicking on any display
group window to display the right-click menu and selecting a style from the Display Window Style
submenu. Use the ENVI main menu bar File > Preferences > Display Defaults tab to change the
default settings for which windows you wish to display and where you wish to position them.

All windows can be resized by grabbing and dragging a window corner with the left mouse button.
1. Resize the Image window to be as large as possible (until the Scroll window disappears).

2. Now, make the Image window smaller than the full extent of the image data (the Scroll window
will reappear).

3. Resize the Zoom window and notice how the outlining box changes in the Image window.

ENVI Main Menu Bar

In ENVI, activities are initiated by using the menus in the ENVI main menu bar, which may be oriented
horizontally as shown below, or vertically (as set via the option on the File > Preferences >
Miscellaneous tab).

& ENVI 4.7

File Basic Tools Classification  Transform  Filker  Spectral Map  Yector Topographic  Radar  ‘Window  Help
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Right-Click Menus

Each of the three display windows has a right-click menu for accessing general display settings and
some interactive functions. Access this menu by right-clicking in the window.
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The Image Window

The Image window shows a portion of the image at full resolution.
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The Display Group Menu Bar

The menu bar in the display group provides access to many ENVI features related to the images in the
display group. This menu appears at the top of the Image window by default. If you have chosen to
display only the Scroll and Zoom windows or just the Zoom window, the menu bar will appear at the top
of the Zoom window.

The Image Window Zoom Box

The Zoom box (the colored box in the Image window) indicates the region that is displayed in the Zoom
window.

1. Place the mouse cursor in the Zoom box in the Image window, hold down the left mouse button,
and move the mouse. The Zoom window is updated automatically when the mouse button is
released.

2. Place the cursor anywhere in the Image window (outside of the Zoom box) and click the left
mouse button to move the magnified area instantly. If you click, hold, and drag the left mouse
button in this fashion, the Zoom window is updated as you drag.

3. Click once in the Zoom box in the Image window and use the arrow keys on your keyboard to
move the box. To move several pixels at a time, hold down the Shift key while using the arrow
keys.

Scroll Bars

You can choose to have scroll bars displayed in the Image window. These scroll bars provide a way to
move through the Scroll window, allowing you to select which portion of the image appears in the Image
window.

1. Right-click in the Image window and select Toggle > Display Scroll Bars.

2. To have scroll bars appear in the Image window by default, use the ENVI main menu bar to
select the File > Preferences > Display Defaults tab. Set the Image Window Scroll Bars toggle
to Yes.

The Zoom Window

The Zoom window shows a portion of the image magnified the number of times indicated by the number
shown in parentheses in the Title Bar of the window. The zoom area is indicated by a highlighted box
(the Zoom box) in the Image window.
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& 21 Joom [4x] |__| |E|['S_(|
Zoorm Level — = == [

Zoorm confrols

There are three Zoom controls (red by default) in the lower left corner of the Zoom window. These
control the zoom factor and the crosshair cursor in both the Zoom and Image windows.

1. Place the mouse cursor in the Zoom window and click the left mouse button to reposition the
magnified area (displayed in the Zoom box in the Image window) by centering the zoomed area
on the selected pixel.

2. Click and hold the left mouse button in the Zoom window while dragging. This causes the Zoom
window to pan within the Image window.

3. Click the left mouse button on the [=] graphic in the lower left corner of the Zoom window to
zoom out by a factor of 1.

4. Using a three button mouse, click the middle mouse button on the [=] graphic to zoom out by a
factor of 2.

5. Click the right mouse button on the [=] graphic to return the Zoom window to the default zoom
factor.

6. Click the left mouse button on the graphic to zoom in by a factor of 1.
7. Click the middle mouse button on the [*) graphic to zoom in by a factor of 2.

8. Click the right mouse button on the *| graphic to return the Zoom window to the default zoom
factor.

9. Click the left mouse button on the [] graphic to toggle the crosshair cursor in the Zoom window
on or off.

10. Click the middle mouse button on the [] graphic to toggle the crosshair cursor in the Image
window on or off.

1. Click the right mouse button on the [ graphic to toggle the Zoom box in the Image window on or
off.

12. The Zoom window can also have optional scroll bars, which provide an alternate method for
moving through the Zoom window. Right-click in the Zoom window and select Toggle > Zoom
Scroll Bars. To have scroll bars appear on the Zoom window by default, use the ENVI main




CYENVI ENVI Tutorial: A Quick Startto ENVI

menu bar to select the File > Preferences > Display Defaults tab. Set the Zoom window Scroll
Bars toggle to Yes.

The Scroll Window

The Scroll window displays the entire image at reduced resolution (subsampled). The subsampling factor
is listed in parentheses in the window Title Bar at the top of the image. The highlighted Image box (red
by default) indicates the area shown at full resolution in the Image window.

Subsarnpling Factor

Irmage Box

1. Place the mouse cursor inside the Image box, hold down the left mouse button, drag to the desired
location, and release to reposition the portion of the image shown in the Image window. The
Image window is updated automatically when the mouse button is released.

2. Click anywhere within the Scroll window using the left mouse button to instantly move the
selected Image window area. If you click, hold, and drag the left mouse button in this fashion, the
Image window will be updated as you drag (the speed depends on your computer resources).

3. Click in the Image box and press the arrow keys on your keyboard. To move the image in larger
increments, hold down the Shift key while using the arrow keys.
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Applying a Contrast Stretch

By default, ENVI displays images with a 2% linear contrast stretch. You can choose to apply a different
contrast stretch.

1. From the Display group menu bar, select Enhance to display a list of six default stretching
options for each of the windows in the display group (Image, Zoom, Scroll).

2. Select an item from the list (for example, Enhance > [Image] Equalization to apply a histogram
equalization contrast stretch to the Image window). This action also updates the Scroll and Zoom
windows in the display group. Try applying several of the different available stretches.

3. Alternatively, you can define your contrast stretch interactively by selecting Enhance >
Interactive Stretching from the Display group menu bar.

10
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Applying a Color Map
By default, ENVI displays images using a grayscale color table. You can apply a pre-defined color table
to an image or select a color table from a list.

1. From the Display group menu bar, select Tools > Color Mapping > ENVI Color Tables to
display the ENVI Color Tables dialog.
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2. Select a color table from the list at the bottom of the dialog to change the color mapping for the
three windows in the display group.

3. Inthe ENVI Color Tables dialog, Auto Apply is selected by default (Options > Auto Apply), so
the color table will automatically be applied. You can toggle this feature on or off using this menu
option. If Auto Apply is off, you must select Options > Apply each time you wish to apply the
color table and observe the results.

4. From the ENVI Color Tables menu bar, select Options > Reset Color Table to return the display
group to the default grayscale color mapping.

5. From the ENVI Color Tables menu bar, select File > Cancel to dismiss the dialog.

11
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Animating Your Image

You can animate a multiband image by cycling through the bands of the image sequentially.

1. From the Display group menu bar, select Tools > Animation then click the OK button on the
Animation Input Parameters dialog. Each of the six bands from the TM scene is loaded into an
Animation window. Once all the bands are loaded, the images are displayed sequentially creating
a movie effect.

Y ou can control the animation using the player control buttons (loop backward, loop forward,
change direction, and pause) at the bottom of the Animation window, or by adjusting the value
shown in the Speed spin box to change the speed at which the bands are displayed.

2. From the Animation menu bar, select File > Cancel to end the animation.

12
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Using Scatter Plots and Regions of Interest

Scatter plots allow you to quickly compare the values in two spectral bands simultaneously. ENVI
scatter plots enable a quick 2-band classification.

1.

10.

From the Display group menu bar, select Tools > 2D Scatter Plots to display the distribution of
pixel values between Band 1 and Band 4 of the image as a scatter plot. The Scatter Plot Band
Choice dialog appears.

Under Choose Band X, select Band 1. Under Choose Band Y, select Band 4. Click OK to
create the scatter plot.

Place the cursor in the Image window (but not inside the Zoom box), then click and drag using the
left mouse button to move the cursor around in the window. As you move the cursor, you will
notice different pixels are highlighted in the scatter plot, making the pixels appear to “dance.” The
dancing pixels in the display are the highlighted 2-band pixel values found in a 10-pixel by 10-
pixel region centered on the cursor.

Define a region of interest (ROI) in the Scatter Plot window. To do this, click the left mouse
button several times in different areas in the Scatter Plot window. Doing this selects points to be
the vertices of a polygon. Click the right mouse button when you are done selecting vertices. This
closes the polygon. Pixels in the Image and Zoom windows whose values match the values
contained in the selected region of the scatter plot are highlighted.

To define a second ROI, left-click a few times in the scatter plot to define the vertices of the next
ROI class, and right-click to close the new polygon.

From the Scatter Plot menu bar, select Class > New and repeat the actions described in the step
4,

From the Scatter Plot menu bar, select Class > Items 1:20, choose the color for your next ROI,
and repeat the actions described in step 4.

From the Scatter Plot menu bar, select Options > Export All to export the regions of interest. The
ROI Tool dialog appears. The ROI Tool dialog can also be started from the menu bar in the
Image window by selecting Overlay > Region of Interest.

From the ROI Tool menu bar, select File > Cancel to dismiss the dialog. The region definition is
saved in memory for the duration of the ENVI session.

From the Scatter Plot menu bar, select File > Cancel to close the Scatter Plot window.

13
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Loading an RGB Image

ENVI allows you to simultaneously display multiple grayscale and/or RGB color composite images.

L.

Click on the Available Bands List. If you dismissed the Available Bands List during the previous
exercises, you can recall it from the ENVI main menu bar by selecting Window > Available
Bands List.

Click on the RGB Color radio button in the Available Bands List. Red, Green, and Blue fields
appear in the middle of the dialog.

Select Band 7, Band 4, and Band 1 sequentially from the list of bands at the top of the dialog by
left-clicking on the band names. The band names are automatically entered in the Red, Green,
and Blue fields.

Click the Display #1 button at the bottom of the Available Bands List and select New Display.
Click Load RGB to load the image into ENVI.

14
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Classifying an Image

ENVI provides two types of unsupervised classification and several types of supervised classification.
The following example demonstrates one of the supervised classification methods.

1.
2.

From the ENVI main menu bar, select Classification > Supervised > Parallelepiped.

In the Classification Input File dialog, select can _tmr. img, and click OK. The Parallelepiped
Parameters dialog appears.

Select the regions of interest (ROIs) you created previously by clicking on the region name in the
Select Classes from Regions list at the left of the dialog.

& parallelepiped Parameters
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Output Resultta © File & Memoary

Scatter Plat Export [Blue] 86 points

Mumber of items selected: |1

Select Al ltems | Clear All Iterms | Output Rule Images 7|No ﬂ
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Max stdew fram Mean|3.00
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Select Memory in the upper right corner of the dialog to output the result to memory.

Set the Output Rule Images toggle to No, then click OK. The classification function calculates
statistics, and a progress window appears during the classification. A new entry called Parallel
(CAN _TMR.IMG) is added to the Available Bands List.

In the Available Bands List, click Display #1 and select New Display.

In the Available Bands List, select the Gray Scale radio button, click on Parallel (CAN_
TMR.IMG), and select Load Band. A new display group containing the classified image is
loaded.

15
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Dynamically Overlaying Images
You can link two display groups, allowing direct comparison of the images by displaying one on top of
the other.

1. From either of the two Display group menu bars, select Tools > Link > Link Displays. The Link
Displays dialog appears. Click OK to link at the origin.

2. In either of the two Image windows, position the cursor outside the Zoom box and click and hold
the left mouse button. A portion of the second image is superimposed over the first image.

3. Change the size of the superimposed area by clicking and dragging the middle mouse button until
the superimposed area is the desired size, then click and hold the left mouse button again.

4. Close the two display groups by selecting File > Cancel from each of the Display group menu
bars.

16
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Overlaying and Working with Vectors

ENVI provides a full suite of vector viewing and analysis tools, including input of ArcView shapefiles,
vector editing, and vector querying.

1.

10.

11.
12.

Click on TM Band 4 in the Available Bands List, click the Gray Scale radio button, then click
Load Band to re-display the grayscale image.

From the ENVI main menu bar, select File > Open Vector File to open a vector file.

In the Select Vector Filenames dialog, navigate to the can tm directory, click can_v1.evf,
hold the Shift key down and click the last file (can v4.evf) from the list (all four . evf files
should be selected), then click Open. The Available Vectors List dialog appears listing the
vectors corresponding to the can _tmr . img display.

Click on one of the vector layer names and examine the information about the layer at the bottom
of the Available Vectors List.

Click the Select All Layers button near the bottom of the dialog to select all of the listed vectors
to plot, then click the Load Selected button.

When the Load Vector Layer dialog appears, click Display #1 to load the vectors into the first
display. The vector layers are listed in the #1 Vector Parameters dialog.

In the Display #1 Vector Parameters dialog, click Apply to load the vectors onto the image. From
the Vectors Parameters menu bar, select Options > Vector Information to start an information
dialog about the vectors.

To display the currently selected vector layer and list basic information about the vectors, click
and drag using the left mouse button in the Image window.

Click on another layer name in the Vector Parameters dialog then click and drag in the Image
window to track a different layer.

From the Vector Parameters menu bar, select Edit > Edit Layer Properties. Change vector
layer parameters as desired and click OK.

In the Vector Parameters dialog, click Apply to display the changes.

You can finish your ENVI session from the ENVI main menu bar File > Exit option. Answer Yes
to the "Terminate this ENVI Session?" prompt. All files are closed automatically.
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