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Image Georeferencing and Registration

This tutorial provides basic information about georeferenced images in ENVI and provides a starting
point for conducting image-to-image and image-to-map registration using ENVI. It assumes that you are
already familiar with general image-registration and resampling concepts. This tutorial is designed to be
completed in about 1 to 2 hours.

Files Used in this Tutorial
ENVI Resource DVD: Data\bldr reg

File Description

bldr_sp.img (.hdr) [Boulder SPOT georeferenced image subset
bldr tm.img (.hdr) [Non-georeferenced Boulder TM data

bldr tm.pts GCPs for TM-SPOT image-to-image registration
bldrtm m.pts GCPs for TM-Map registration
bldr rd.dlg Boulder roads DLG

File Description

bldr_tml.wrp (.hdr) |Image-to-image result using RST and nearest neighbor

bldr_tmZ2.wrp (.hdr) [Image-to-image result using RST and bilinear interpolation

bldr_ tm3.wrp (.hdr) |Image-to-image result using RST and cubic convolution

bldr_tm4.wrp (.hdr) |Image-to-image result using 1st degree polynomial and cubic convolution

bldr_tm5.wrp (.hdr) |Image-to-image result using Delaunay triangulation and cubic convolution

bldrtm m.img (.hdr) [Image-to-map result using RST and cubic convolution for the Boulder TM
data

bldrtmsp.img (.hdr) | Boulder TM/SPOT sharpening result using HSV sharpening, 10 meter
pixels

Background

ENVI provides full support for georeferenced images in numerous predefined map projections including
UTM and State Plane. In addition, ENVI’s user-configurable map projections allow construction of
custom map projections utilizing 30 standard projection types. In addition to the projections listed in
Table D-8, ENVI also reads any projection type from a geodatabase or ESRI® layer file. See ArcGIS®
Help for a full list of supported projections, or refer to the Tech Tip “ESRI® Projection Engine
Reference v1.0” on the ITT Visual Information Solutions website.

ENVI map projection parameters are stored in an ASCII text file map proj.txt that you can edit or
modify using ENVI map projection utilities. The information in this file is used in the ENVI header files
associated with each image and allows simple association of a reference pixel location with known map
projection coordinates. Selected ENVI functions can then use this information to work with the image in
georeferenced data space.
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ENVI’s image registration and geometric correction utilities allow you to reference pixel-based images
to geographic coordinates and/or correct them to match base image geometry. Ground control points
(GCPs) are selected using the Image and Zoom windows for both image-to-image and image-to-map
registration. Coordinates are displayed for both base and uncorrected image GCPs, along with error
terms for specific warping algorithms. Next GCP point prediction allows simplified selection of GCPs.

Warping is performed using resampling, scaling and translation (RST), polynomial functions (of order 1
through n), or Delaunay triangulation. Resampling methods supported include nearest-neighbor, bilinear
interpolation, and cubic convolution. Comparison of the base and warped images using ENVI’s multiple
dynamic overlay capabilities allows quick assessment of registration accuracy.

The following sections provide examples of some of the map-based capabilities built into ENVI. Consult
ENVI Help for additional information.
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Opening and Displaying Georeferenced Data

Before attempting to start the program, ensure that ENVTI is properly installed as described in the
Installation Guide that shipped with your software.

1. From the ENVI main menu bar, select File > Open Image File.

2. Navigate to the Data\bldr reg directory, select the file bldr sp.img from the list, and
click Open. The Available Bands List appears.

3. From the Available Bands List, select the Georeferenced SPOT band from the list and click
Load Band to load the image into a new display group.

Viewing Map Info in the ENVI Header

1. Inthe Available Bands List, right click on the Map Info icon and select Edit Map Information.
The Edit Map Information dialog appears.
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This dialog lists the basic map information used by ENVI in georeferencing. The image
coordinates correspond to a reference pixel used by ENVI as the starting point for the map
coordinate system. Because ENVI knows the map projection, pixel size, and map projection
parameters based on this header information and the map projection text file, it can calculate the
geographic coordinates of any pixel in the image. You can enter coordinates in either map
coordinates or geographic (latitude/longitude) coordinates.
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4.

Click on the projection field toggle button ﬂ to display the latitude/longitude coordinates for the
UTM Zone 13 North map projection. Note that ENVI makes this conversion on-the-fly.

Click the DDEG button then click the DMS button to toggle between degrees-minutes-seconds,
and decimal degrees, respectively.

Click Cancel to exit the Edit Map Information dialog.

Displaying the Cursor Location and Value

You can choose to display the location of your mouse cursor, screen value (RGB color), and the data
value of the pixel underneath the crosshair cursor using the Cursor Location/Value dialog. When several
display groups are open, this dialog specifies which display group’s location and value are being
reported.

1.

3.
4.

To display the cursor location and value, select Window > Cursor Location/Value from either
the ENVI main menu bar or the Display group menu bar. You can also double-click inside the
Image window.

Move the mouse cursor over the Image, Scroll, or Zoom windows to display location and value
information in the Cursor Location/Value dialog. Note that the coordinates are given in both pixels
and georeferenced coordinates for this georeferenced image. Also note the relation between map
coordinates and latitude/longitude.

From the Cursor Location/Value menu bar, select File > Cancel to close the dialog.

Keep the display group open for the next exercise.




ENVI Tutorial: Image Georeferencing and Registration @ENV|

Image to Image Registration

This section of the tutorial takes you step-by-step through Image to Image Registration. The
georeferenced SPOT image will be used as the base image, and a pixel-based Landsat TM image will
be warped to match the SPOT.

1. From the ENVI main menu bar, select File > Open Image File.

2. Navigate to the Data\bldr reg directory, select the file bldr tm.img from the list, and
click Open. The Available Bands List appears and the RGB image is automatically loaded into a
new display group.

3. Double-click in the Image window to display the Cursor Location/Value tool.

4. Move the mouse cursor over the Image, Scroll, or Zoom windows to display location and value
information in the Cursor Location/Value dialog. Note that the coordinates are given in pixels
since this is a pixel-based image rather than a georeferenced image like the SPOT data you used
in the previous exercise.

5. From the Cursor Location/Value menu bar, select File > Cancel to close the dialog.

Starting Image Registration and Loading Ground Control Points

1. From the ENVI main menu bar, select Map > Registration > Select GCPs: Image to Image.
The Image to Image Registration dialog appears.

2. Inthe Base Image field, select Display #1 (the SPOT image). In the Warp Image field, select
Display #2 (the TM image)

3. Click OK to start the registration. The Ground Control Points Selection dialog appears.
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4. You can add individual ground control points (GCPs) by positioning the cursor in the two images
to the same ground location. In the Base field, type 753 for the x location and 826 for the y
location. Press the Enter key after typing each value, to move the cursor in the SPOT image. In
the Warp field, type 331 for the x location and 433 for the y location to move the cursor in the
TM image.

5. Examine the locations in the two Zoom windows and adjust the locations if necessary by clicking
the left mouse button in each Zoom window at the desired locations. Note that sub-pixel
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10.

11.

12.

positioning is supported in the Zoom windows. The larger the zoom factor, the finer the
positioning capabilities.

In the Ground Control Points Selection dialog, click Add Peint to add the GCP to the list. Click
Show List to view the GCP list. Try this for a few points to get a feel for selecting GCPs. Note

the list of actual and predicted points in the dialog. Once you have at least four points, the RMS
error is reported.

From the Ground Control Points Selection dialog menu bar, select Options > Clear All Points to
clear all of your points.

From the Ground Control Points Selection dialog menu bar, select File > Restore GCPs from
ASCIL

Navigate to the Data\bldr regq directory, select the file bldr tm.pts from the list, and
click Open. Previously saved GCP parameters are loaded into the dialog.

Try positioning the cursor at a new location in the Image window containing the SPOT image.
Click the Predict button to move the cursor position in the TM image to match its predicted
location based on the warp model.

The exact position can now be interactively refined by moving the pixel location slightly in the
TM data.

Click Add Point in the Ground Control Points Selection dialog to add the new GCP to the list.

Working With GCPs

The following image provides descriptions of the features and functions available in the Image to Image
GCP List. Click Show List to view the GCP list. Click on individual GCPs in the Image to Image GCP
List dialog and examine the locations of the points in the two images, the actual and predicted
coordinates, and the RMS error. Resize the dialog to observe the total RMS Error listed in the Ground
Control Points Selection dialog.
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Warping Images
Images can be warped from the displayed band, or multiband images can be warped all bands at once.

For this exercise you will warp only the displayed band.

1. From the Ground Control Points Selection dialog menu bar, select Options > Warp Displayed
Band. The Registration Parameters dialog appears.

2. Click the Method drop-down list and select RST.
3. Ensure the Resampling drop-down list has the Nearest Neighbor option selected.

4. In the Enter Output Filename field, type bldr tml.wrp as the new filename and click OK.
The warped image is listed in the Available Bands List when the warp is completed.

5. From the Ground Control Points Selection dialog menu bar, select Options > Warp Displayed
Band. The Registration Parameters dialog appears.

6. Click the Method drop-down list and select RST.
7. Click the Resampling drop-down list and select Bilinear.

8. In the Enter Output Filename field, type bldr tm2.wrp as the new filename and click OK.
The warped image is listed in the Available Bands List when the warp is completed.

9. Repeat steps 5 — 8 using the RST method and Cubic Convolution resampling, then name the
output file bldr tm3.wrp.

10. Repeat steps 5 — 8 using the Polynomial method and Cubic Convolution resampling, then name
the output file b1dr tm4.wrp.

11. Repeat steps 5 — 8 using the Triangulation method and Cubic Convolution resampling, then
name the output file bldr tm5.wrp.

Comparing Warp Results
Now you will use dynamic overlays to compare your warp results:

1. In the Available Bands List, click once to select the bldr tm.img file, then select File >
Close Selected File from the menu bar. In the subsequent ENVI warning dialog, click Yes to
close the associated display group.

2. Inthe Available Bands List, select the bldr tml.wrp file, click the Display # drop-down
button, select New Display, then click Load Band to load the file into the new display.

3. Right-click in the Image window and select Link Displays. The Link Displays dialog appears.
4. Click OK in the Link Displays dialog to link the SPOT and the registered TM image.

5. Compare the SPOT and the TM images using the dynamic overlay by clicking the left mouse
button in the Image window of the TM image.

6. Loadbldr tm2.wrpandbldr tm3.wrp intonew display groups and use the image linking
and dynamic overlays to compare the effect of the three different resampling methods: nearest
neighbor, bilinear interpolation, and cubic convolution. Note how jagged the pixels appear in the
nearest neighbor resampled image. The bilinear interpolation image looks much smoother, but the
cubic convolution image is the best result, smoother, but retaining fine detail.
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10.
11.
12.

13.
14.

Close the bldr tml.wrpandbldr tm2.wrp display groups (select File > Cancel from the
associated Display group menu bars).

Load bldr tm4.wrpandbldr tm5.wrp into new display groups, and use the image linking
and dynamic overlays to compare to bldr tm3.wrp (RST Warp).

Note the effect of the three different warping methods: RST, 1st degree Polynomial, and
Delaunay Triangulation on the image geometry.

Use dynamic overlay to compare to the georeferenced SPOT data.
To display the Cursor Location/Value tool, double-click in the Image window.

Browse the georeferenced datasets and note the effect of the different resampling and warp
methods on the data values.

From the Display group menu bar, select File > Cancel to close the dialog.

From the ENVI main menu bar, select File > Close All Files to close all of the data files. Click
Yes on the corresponding warning dialog.
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Image to Map Registration

This section of the tutorial will take you step-by-step through an Image to Map registration. Many of the
procedures are similar to Image to Image registration and will not be discussed in detail. The map
coordinates picked from the georeferenced SPOT image and a vector Digital Line Graph (DLG) will be
used as the base image, and the pixel-based Landsat TM image will be warped to match the map data.

Opening and Displaying a SPOT Image File
1. From the ENVI main menu bar, select File > Open Image File.

2. Navigate to the Data\bldr reg directory, select the file bldr sp.img from the list, and
click Open. The Available Bands List appears.

3. Select Georeferenced SPOT under bldr sp.img, and click Load Band. The georeferenced
SPOT image appears in a new display group.

Opening and Displaying a Landsat TM Image File
1. From the ENVI main menu bar, select File > Open Image File.

2. Navigate to the Data\bldr reg directory, select the file bldr tm.img from the list, and
click Open. A Landsat TM RGB image is automatically loaded into a new display group.

Selecting Image-to-Map Registration and Restoring GCPs

1. From the ENVI main menu bar, select Map > Registration > Select GCPs: Image to Map. The
Image to Map Registration dialog appears.

2. From the Display #1 drop-down menu, select Display #2. You will warp the Landsat TM image
(in Display #2) to match the georeferenced SPOT image.

Ensure UTM is selected as the projection.

Type 13 in the Zone field.

Enter 10.0 in the X/Y Pixel Size fields. SPOT data have a spatial resolution of 10m.
Click OK to start the registration. The Ground Control Points Selection dialog appears.

NS kW

From the Ground Control Points Selection dialog menu bar, select File > Restore GCPs from
ASCIL.

8. Navigate to the Data\bldr reg directory, select the file bldrtm m.pts from the list, and
click Open. Previously saved ground control point parameters are loaded into the dialog.

9. In the Ground Control Points Selection dialog, click Show List. The Image to Map GCP List
dialog appears. Examine the base map coordinates, the actual and predicted image coordinates,
and the RMS error.

Adding Map GCPs Using Vector Display of DLGs

1. From the ENVI main menu bar, select File > Open Vector File.

2. From the Files of type drop-down list, select USGS DLG.

10
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10.
11.

12.

13.

Navigate to the Data\bldr regq directory, select the file bldr rd.dlg from the list, and
click Open. The Import Vector Files Parameters dialog appears.

In the Import Vector Files Parameters dialog, click the Memeory radio button, then click OK to
read the DLG data. The Available Vectors List dialog appears.

Select the ROADS AND TRAILS: BOULDER, CO file, then click Load Selected.
Select Display #1 and click OK. The Vector Parameters: Cursor Query dialog appears.

Return to the Load Vector dialog. From The Available Vectors List dialog, select the ROADS
AND TRAILS: BOULDER, CO file, then click Load Selected.

Select New Vector Window, and click OK. This loads the vectors into a new vector window.

& Vector Window #1 : Cursor Query
Fie Mode Edk Optiors Help
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40" 258N, 1051 545,65 Actrvs: "ROADS AND TRAILS: BOULDER, CO™

Click and drag the mouse in the vector window to activate a crosshair cursor. The map
coordinates of the cursor will be listed at the bottom of the vector window.

From the Display group menu bar in the TM image, select Tools > Pixel Locator.

Type 402 in the Sample field and 418 in the Line field, then click Apply to place the cursor on
the road intersection. Note that sub-pixel positioning accuracy is again available in the Zoom
window.

In the Vector window, position the vector cursor at the road intersection at approximately
477593.74, 4433240.0 (40° 3' 3" N, -105° 15' 45" W) by clicking and dragging with the left mouse
button and releasing when the circle at the crosshair intersection overlays the intersection of
interest.

Right-click in the vector window and select Export Map Location. The new map coordinates
will appear in the Ground Control Points Selection dialog.

11
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14.

In the Ground Control Points Selection dialog, click Add Point to add the map-coordinate/image
pixel pair and observe the change in RMS error.

RST and Cubic Convolution Warping

1.

o vop W

From the Ground Control Points Selection dialog menu bar, select Options > Warp File. The
Input Warp Image dialog appears.

Select the bldr tm.img file, and click OK to select all six TM bands for warping. The
Registration Parameters dialog appears.

Click the Method drop-down list, and select RST.
Click the Resampling drop-down list, and select Cubic Convolution.
In the Background field, type 255.

In the Enter Output Filename field, type bldrtm m.img as the new filename, and click OK.
The warped image is listed in the Available Bands List and automatically loaded into a new
display group when the warp is completed.

Note the skew of the image resulting from removal of the Landsat TM orbit direction. This image
is georeferenced, but at 30 meter resolution versus the 10 meter resolution provided by the SPOT
image.

Displaying and Evaluating Results

1.
2.

From the ENVI main menu bar, select File > Open Image File.

Navigate to the Data\bldr regq directory, select the file bldr sp.img from the list, and
click Open. The Available Bands List appears.

From the Available Bands List, select the Georeferenced SPOT band from the list, click the
Display # drop-down button, and select New Display.

Click Load Band to load the SPOT image into a new display group.
Compare the image geometries and scale.

From the Ground Control Points Selection dialog menu bar, select File > Cancel to close that
dialog. Save the GCPs if desired. Now that you have learned how to perform Image to Image and
Image to Map registration, refer to the Map Composition tutorial for guidance on adding grid lines
and creating image maps in ENVI.

You can quit your ENVI session by selecting File > Exit from the ENVI main menu bar.

12
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