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Linear Feature Extraction with Intelligent Digitizer

This tutorial shows you how to use ENVI’s Intelligent Digitizer to extract linear features, such as roads,
coastlines, lake boundaries, and rivers as vector data.

Files Used in this Tutorial
ENVI Resource DVD: Datalselmivis

File Description

selinunte_rad.bil | MIVIS Radiance Data, Selinunte, Italy, 92 bands

selinunte_rad.hdr | Header for the above file

ENVI Resource DVD: Data\ortho

File Description
po_101515 pan 0000000.tif | Panchromatic IKONOS data of La Jolla, CA, one band
po_101515_pan_0000000.hdr | Header for the above file

About Intelligent Digitizer

With Intelligent Digitizer, you place seed points along the path of a feature and ENVI automatically
finds the intermediate points. By using this method, Intelligent Digitizer reduces the number of mouse
clicks you use to extract a feature, resulting in saved time and improved accuracy over traditional heads-
up digitization. You can also toggle between intelligent mode and ENVI’s standard vector tool mode
when needed, such as when contrast is low or there are big disturbances in the linear features, to ensure
the feature selection is accurate. You can extract features using a single band or multiple bands. Using
Intelligent Digitizer on properly-selected multiple bands increases the accuracy of your results.

With Intelligent Digitizer, you can perform automatic post-processing procedures to improve the quality
of the feature extractions, and as with ENVI’s standard vector tool, you can manually manage vectors,
perform basic vector editing, and convert vectors to external formats such as shapefiles.

When extracting linear features, it is best to create separate layers for different feature types. The
exercises that follow have you create one layer for coastline extraction from a multiband image, and
another layer for road extraction from a single band image. Both examples extract the feature with a
polyline. If you want to extract a feature such as a lake boundary, you use polygon mode.

Opening a File for Coastline Extraction

1. From the ENVI main menu bar, select Vector > Intelligent Digitizer. The Intelligent Digitizer
Input File dialog appears.

2. Click Open, then select New File. The Please Select a File dialog appears.

3. Navigate to the Data\selmivis directory, select the file selinunte rad.bil, and click
OK. The File Spectral Subset dialog displays.

4. Click OK to accept the default bands to use for intelligent digitization (bands 6, 11, and 20). The
image opens in a display group. The Vector Parameters dialog also opens, with menu options for
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Intelligent Digitizer enabled. ENVI adds a new layer named Intelligent Digitizer: New Layer to
the Available Vector Layers area of the Vector Parameters dialog.

A Note About Opening Multiband Files

If the image has three or fewer bands, the image opens in a display group, with all three bands selected
for use in the Intelligent Digitizer.

If the image has more than three bands, the File Spectral Subset dialog appears with pre-selected bands.
It is recommended that you select six or fewer bands. Using more than six bands slows system
performance.

ENVI pre-selects bands as follows:

o If the image has four bands, ENVI selects bands 3 and 4, typically the red and near-infrared
bands.

o If the image has more than four bands and also has wavelength information, ENVI selects a
color-infrared combination of bands.

o If the image has more than four bands but does not have wavelength information, ENVI selects
the bands as [nb/3, nb/2, nb*2/3] forred, green, and blue, where nb is number of
bands.

Extracting a Coastline

Using the layer named Intelligent Digitizer: New Layer, this exercise shows you how to
select seed points that define the coastline, and how to rename the layer.

When extracting features such as coastlines or lake boundaries, you can change the extraction width in
the Intelligent Digitizer Parameters dialog to 1.00. To do this, select Mode > Intelligent Digitizer
Parameters to open the Intelligent Digitizer Parameters dialog. Change the Linear Feature Width
(Pixels) value to 1.00.

1. From the Display group menu bar, select Tools > Pixel Locator. The Pixel Locator dialog
appears.

2. Enter the Sample as 1 and the Line as 501, then click Apply to move to the beginning of the
coastline shown in the image below.
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3. In the Image window, begin left-clicking at intervals to add seed points that mark the coastline.
ENVI automatically connects one seed point to the next seed point. The example above shows the
seed points as solid black boxes and the nodes added by ENVI as white outlined boxes.

Here are some tips for extraction:
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e For sharp curves along the coastline, select seed points at the sharp curves.

o If the placement of a seed point does not extract the feature as desired, middle-click to
remove the last seed point, then select a new seed point closer to the seed point you
removed. You can middle-click more than once to remove seed points in reverse order,
one at a time.

o If the spectrum of the coastline changes abruptly, select a seed point a few pixels
beyond the surface change.

4. Continue adding seed points until you define the entire coastline. After you add the final seed
point, right-click to set the point, then right-click again and select Accept New Polyline.
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5. From the Vector Parameters dialog menu bar, select Edit > Save Changes Made to Layer to
save the layer to memory, then close the Vector Parameters dialog. The remaining steps show you
how to rename your layer and save it to a file.

6. From the ENVI main menu bar, select Vector > Available Vectors List. The Available Vectors
List displays, with the layer named Intelligent Digitizer: New Layer in the Available Vector
Layers area.

7. From the Available Vectors List menu bar, select Options > Edit Layer Names. The Edit Layer
Names dialog appears.
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10.

11.

12.

Select the layer named Intelligent Digitizer: New Layer, type the name Selinunte
Coastline inthe Edit Selected Item field, then click OK. The new layer name appears in the
Available Vector Layers area of the Available Vectors List.

Select the Selinunte Coastline layer, then from the Available Vectors List menu bar
select File > Save Memory Layers to File. The Save Memory Layer to File dialog appears.

Enter the filename Selinunte Coastline.evf inthe Enter Output Filename [.evf] field,
then click OK.

In the Available Vectors List, select the layer name in the Available Vector Layers area and
click Load Selected. The Load Vectors dialog displays.

Select Display #1 and click OK. ENVI overlays the vector on the image. The Vector Parameters
dialog appears, with the new layer name in the Available Vector Layers area.

Opening a File for Road Extraction

1.

From the ENVI main menu bar, select Vector > Intelligent Digitizer. The Intelligent Digitizer
Input File dialog appears.

Click Open, then select New File. The Please Select a File dialog appears.

Navigate to the Data\ortho directory, select the file po 010515 pan 00000000.tif,
and click OK. The image opens in a display group. The Vector Parameters dialog also opens,
with menu options for Intelligent Digitizer enabled. ENVI adds a new layer named Intelligent
Digitizer: New Layer added to the Available Vector Layers area of the Vector Parameters
dialog.

Extracting Roads

This exercise shows you how to create a new layer and extract roads with intersections and a highway
with overpasses.

If you changed the Linear Feature Width (Pixels) value to 1.00 in the previous exercise to extract the
coastline, reset the value to 15.00 before you extract roads.

1.

In the Scroll window, move the Image box to an area containing roads, preferably roads that
intersect. You can use the Pixel Locator tool to find areas for extraction. Some suggested areas to
extract include the following:

Sample = 4532, Line = 2479, for an area of highway that contains overpasses

Sample = 1301, Line = 3349, for an area of streets and intersections

Sample = 3263, Line = 4470, for an area of streets and intersections

Sample = 2863, Line = 1631, for an area of streets and intersections

Click the Maximize button in the Image window title bar to enlarge the Image window.

From the Vector Parameters dialog menu bar, select File > Create New Layer. The New Vector
Layer Parameters dialog appears.

4. Type the name LaJolla CA Roads inthe Layer Name field.




ENVI Tutorial: Linear Feature Extraction with Intelligent Digitizer @ENV|

5. Select output to File and enter the filename LaJolla CA Roads.evf in the Enter Output
Filename [.evf] field. If needed, click Choose to change the directory to which to save the file.

6. Click OK. The new layer appears in the Vector Parameters dialog.

7. In the Image window, begin left-clicking at intervals to add seed points that mark the roads you
want to extract. ENVI automatically connects one seed point to the next seed point. Here are
some tips for extraction:

o For road centerline extraction, select seed points near the road centerline.
o For sharp curves in the road, select seed points at the sharp curves.

o If the placement of a seed point does not extract the feature as desired, middle-click to
remove the last seed point, then select a new seed point closer to the seed point you
removed. Clicking on a location closer to the previous seed point will likely give a
better result. You can middle-click more than once to remove seed points in reverse
order, one at a time.

o At intersections, extend the start or end node beyond the point where the two roads
intersect. You will use automatic post-processing in a later step to remove dangling
lines.

e In areas that do not provide sufficient contrast between the feature and its background,
or in areas of roadways with overpasses, press and hold the Shift key to temporarily
disable intelligent mode, then left-click to define the feature through the area. When you
are past the area, release the Shift key to resume using intelligent mode. For example:

In an area with
overpasses and shadows,
adding seed points in
intelligent mode results in
an extradion like this,

o

| Use Shift plus left-click
| to disable inkeligent
mode through the area
| o get an extraction like

8. When you have enough seed points added to define a road, right-click to set the final seed point,
then right-click again and select Accept New Polyline. Optionally, if you are extracting a road
that is near another road (or roads) that is already extracted, you can snap the node(s) to the
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, Snap End Node to Nearest Polyline, or Snap Both Ends to Nearest Polylines from the right-
click menu.

9. Repeat adding seed points for each road you want to extract.

10. From the Vector Parameters dialog menu bar, select Edit > Save Changes Made to Layer.

Using Automatic Post-Processing Tools

After you extract polyline features, you can apply ENVI’s automatic post-processing cleanup tool to
create intersections between polylines that cross one another, and to correct overshooting (dangling)
polylines.

1. Right-click on the LaJolla CA Roads layer in the Vector Parameters dialog and select
Linear Feature Cleanup. The Linear Feature Cleanup Parameters dialog appears.

2. The Dangle Length Tolerance (Pixels) default value is 20.00. ENVI removes any dangling
polylines shorter than this value during automatic linear feature cleanup. You can change this
value in the dialog, if needed.

3. Click OK. ENVI removes any dangling polylines and creates intersections between crossing
polylines. When complete, ENVI overlays the modified layer on the original layer (using a
different Current Layer color). In the Vector Parameters dialog, ENVI adds the new layer
named LaJolla CA Roads clean to the Available Vector Layers list.

The next figures show an example of before and after using Linear Feature Cleanup.

8l Before Linear Feature
Cleanup. MNobe the
dangling polvline.

EMYT overlays the clean laver on
top of the original laver, using a
different color, The dangling
polvling in this example is not part
of the new laver,

4. The following figure shows a large scene with an extracted road network after automatic post-
processing is complete. The original extraction contained dangles, which were removed during the
Linear Feature Cleanup step.
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5. If desired, you can close the original layer (LaJol1la CA Roads) by right-clicking on the layer
name in the Vector Parameters dialog box and selecting Remove Active Layer.

Using Manual Post-Processing Tools

You can further clean up your extraction using manual post-processing features. You can snap one
polyline to one another, and you can extend polylines that you previously extracted. You can also use
ENVT’s standard vector tools to adjust nodes.

Snapping Nodes to Polylines

ENVI uses a default setting of 30.00 pixels to snap nodes to polylines. When you select a node that is
30.00 or fewer pixels away from a polyline, ENVI snaps that node to the polyline when you select the
menu option described in the steps below. You can modify the snap setting by selecting Mode >
Intelligent Digitizer Parameters from the Vector Parameters menu bar and editing the Snap
Tolerance (Pixels) field. You can also disable snapping by setting Snap Tolerance (Pixels) to 0.0.
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From the Vector Parameters dialog menu bar, select Mode > Edit Existing Vectors.
Select the layer to edit from the Available Vector Layers area.

In the Image window, find an area where extracted polylines do not quite meet. Select the
polyline you want to join with a nearby polyline. The polyline nodes appear and the polyline color
changes to red.

Right-click and select Snap End Node to the Nearest Polyline. ENVI connects the end node to
the nearest polyline.

Snap the end
| node tothe
| nearest polvline,

Extending Polylines

1.
2.
3.

From the Vector Parameters dialog menu bar, select Mode > Edit Existing Vectors.
Select the layer to edit from the Available Vector Layers area.

In the Image window, select the polyline you want to extend. The polyline nodes appear and the
polyline color changes.

Right-click on the end node you want to extend and select Extend Selected Vector. The polyline
nodes disappear and the polyline color returns to the current layer color. ENVI automatically
changes to Add New Vectors mode. Verify that Intelligent Digitizer is enabled in the Mode
menu of the ENVI main menu bar. If it is disabled, then enable it.

Add new seed points as you do when you extract a feature. ENVI automatically continues the
vector from the end node and treats the vector as one continuous polyline.

After you select the last seed point, right-click to set it, then right-click again and select Accept
New Polyline.

Calculating Extracted Feature Length

You can calculate the length of extracted features and include the results as the attribute evf length
in the Layer Attributes table. The default units for the evf length attribute are meters.

1.

Right-click on the LaJolla CA Roads clean layer in the Vector Parameters dialog and
select Calculate Length Attribute.

ENVI calculates the EVF length of the features, then displays the results in the evf length
field of the Layer Attributes table.
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